summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 16:00:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:28 +0000
commit51a10d33166a33cf25fd22397382a5684ccf003e (patch)
treeae2229a94ed76fbce5a9be72c4199715441c0912
parentbd4c6bbf0a821387687bb16221c59f0c1563a26e (diff)
gnu: Add go-numcpus.
* gnu/packages/golang-xyz.scm (go-numcpus): New variable. Change-Id: I2edb2f355fd14f2f9a470c91519e7fe1581cc243
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1badc3856c..90942f8991 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1301,6 +1301,20 @@ CPU quota.")
;;; Executables:
;;;
+(define-public go-numcpus
+ (package
+ (inherit go-github-com-tklauser-numcpus)
+ (name "go-numcpus")
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/tklauser/numcpus/cmd/numcpus"
+ #:unpack-path "github.com/tklauser/numcpus"
+ #:install-source? #f))
+ (description
+ "This package provides a CLI build from the
+go-github-com-tklauser-numcpus source.")))
+
(define-public go-pixelmatch
(package
(inherit go-github-com-orisano-pixelmatch)