summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:44:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:47:09 +0200
commit5308f4139edd7fdba2c275327ae625f07b8c269e (patch)
treeef6dd7f8d3068b030463491d9cf536e71847aeec
parent1804a99d055570e7c6e14415790cb7689ce1aa17 (diff)
gnu: Add texlive-convbkmk.
* gnu/packages/tex.scm (texlive-convbkmk): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 23fc16bd25..538540bd6e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4206,6 +4206,27 @@ systems of continued equalities (or inequalities). Several variant layouts of
the equalities are provided, and the user may define their own.")
(license license:lppl1.3+)))
+(define-public texlive-convbkmk
+ (package
+ (name "texlive-convbkmk")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/convbkmk/" "scripts/convbkmk/")
+ (base32
+ "0w4fm4az1smrw002sqjkiiz94x01z6jkrb0mf9wb8qxdwrxriql9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "convbkmk.rb")))
+ (inputs (list ruby))
+ (home-page "https://ctan.org/pkg/convbkmk")
+ (synopsis
+ "Correct pLaTeX/upLaTeX bookmarks in PDF created with @code{hyperref}")
+ (description
+ "The package provides a small Ruby script that corrects bookmarks in PDF
+files created by pLaTeX or upLaTeX, using @code{hyperref}.")
+ (license license:expat)))
+
(define-public texlive-correctmathalign
(package
(name "texlive-correctmathalign")