summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-11 10:29:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-11 11:13:55 +0200
commit5ac2b2717f8d4b05c39c5717843d40bb1a493364 (patch)
treee757209b1c54d1f16c9387783ff3343eb2c04be6
parentc92d056a8b83aa51c2223cc3d840e3d9775e64b7 (diff)
gnu: python-networkx2: Remove variable.
* gnu/packages/python.scm (python-networkx2): Remove variable. * gnu/packages/patches/python-networkx2-reproducible-build.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-networkx2-reproducible-build.patch29
-rw-r--r--gnu/packages/python.scm19
3 files changed, 0 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 545a7d173f..15088a56a2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1080,7 +1080,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-cairocffi-dlopen-path.patch \
%D%/packages/patches/python-fix-tests.patch \
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
- %D%/packages/patches/python-networkx2-reproducible-build.patch \
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
%D%/packages/patches/python-scikit-learn-fix-test-non-determinism.patch \
%D%/packages/patches/python-configobj-setuptools.patch \
diff --git a/gnu/packages/patches/python-networkx2-reproducible-build.patch b/gnu/packages/patches/python-networkx2-reproducible-build.patch
deleted file mode 100644
index 8274767ab8..0000000000
--- a/gnu/packages/patches/python-networkx2-reproducible-build.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From c065b972ed294769a41936d6b9feb336473af5d1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= <boskovits@gmail.com>
-Date: Sat, 4 Nov 2017 15:28:47 +0100
-Subject: Fix SOURCE_DATE_EPOCH ignored bug (#2735)
-
-* Fix SOURCE_DATE_EPOCH ignored bug
-
-Fix a bug in networkx/release.py that makes build
-non-reproducible.
----
- networkx/release.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/networkx/release.py b/networkx/release.py
-index e81fc0c0..6322cf0d 100644
---- a/networkx/release.py
-+++ b/networkx/release.py
-@@ -135,7 +135,7 @@ def get_revision():
-
- def get_info(dynamic=True):
- # Date information
-- date_info = datetime.datetime.now()
-+ date_info = datetime.datetime.utcfromtimestamp(int(os.environ.get('SOURCE_DATE_EPOCH', time.time())))
- date = time.asctime(date_info.timetuple())
-
- revision, version, version_info, vcs_info = None, None, None, None
---
-2.14.2
-
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d90805071b..f4592829a0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5208,25 +5208,6 @@ of the structure, dynamics, and functions of complex networks.")
(define-public python2-networkx
(package-with-python2 python-networkx))
-;; Define new package, because the current version of python-colormath does
-;; not build against 2.0.
-(define-public python-networkx2
- (package (inherit python-networkx)
- (name "python-networkx2")
- (version "2.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "networkx" version ".zip"))
- (sha256
- (base32
- "1ajl2jp8qry9nyjzzkqpy0vmsr14d23z1qk7y0vr5iwjbpvzhpyd"))
- (patches
- (search-patches "python-networkx2-reproducible-build.patch"))))))
-
-(define-public python2-networkx2
- (package-with-python2 python-networkx2))
-
(define-public python-datrie
(package
(name "python-datrie")