summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-05-15 22:14:41 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-15 22:15:35 +0200
commit5c7a58ae7126a7ec9e0861236b2cadb0a5e06d5a (patch)
tree73dafe32591d82d93d3ed8e279d735db92721e8d
parent28995b081ee4fea55dedc3ce5b02c1376de5cbcf (diff)
gnu: libarchive: Ungraft.
* gnu/packages/backup.scm (libarchive)[replacement]: Remove. [source]: Add ‘patches’. (libarchive/fixed): Remove. Change-Id: I32b717c2166a6683043e0169b96f383dc9404b96
-rw-r--r--gnu/packages/backup.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 325a490a94..aa874dc660 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -259,7 +259,6 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(define-public libarchive
(package
(name "libarchive")
- (replacement libarchive/fixed)
(version "3.6.1")
(source
(origin
@@ -269,6 +268,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(string-append "https://github.com/libarchive/libarchive"
"/releases/download/v" version "/libarchive-"
version ".tar.xz")))
+ (patches (search-patches "libarchive-remove-potential-backdoor.patch"))
(sha256
(base32
"1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas"))))
@@ -348,25 +348,6 @@ random access nor for in-place modification. This package provides the
@command{bsdcat}, @command{bsdcpio} and @command{bsdtar} commands.")
(license license:bsd-2)))
-(define-public libarchive/fixed
- (hidden-package
- (package
- (inherit libarchive)
- (version "3.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (list (string-append "https://libarchive.org/downloads/libarchive-"
- version ".tar.xz")
- (string-append "https://github.com/libarchive/libarchive"
- "/releases/download/v" version "/libarchive-"
- version ".tar.xz")))
- (patches (search-patches "libarchive-remove-potential-backdoor.patch"))
- (sha256
- (base32
- "1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas")))))))
-
-
(define-public rdup
(package
(name "rdup")