summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:59:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:45 +0200
commit5e999eef0d051587025f444d06da579a82749f16 (patch)
tree8460f866391589c5b1075027a324eb5dbab36b1f
parent4b35360513a24d441e05280a0a70b1c7be7b5523 (diff)
gnu: Add texlive-stickstoo.
* gnu/packages/tex.scm (texlive-stickstoo): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 093b21f426..7d406c76a2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23901,6 +23901,34 @@ as a Greek complement to a Times-like font such as STEP. The font supports
polytonic Greek.")
(license license:silofl1.1)))
+(define-public texlive-stickstoo
+ (package
+ (name "texlive-stickstoo")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/stickstoo/"
+ "fonts/afm/public/stickstoo/"
+ "fonts/enc/dvips/stickstoo/"
+ "fonts/map/dvips/stickstoo/"
+ "fonts/tfm/public/stickstoo/"
+ "fonts/type1/public/stickstoo/"
+ "fonts/vf/public/stickstoo/"
+ "tex/latex/stickstoo/")
+ (base32
+ "15hmplphlg5vc3a966x379bkn74vb39pv73w0py65nd9zbb7z27i")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/stickstoo")
+ (synopsis "Reworking of STIX2")
+ (description
+ "SticksToo is a reworking of the STIX2 fonts with support files focussing
+on enhancements of support for LaTeX users wishing to be able to access more
+of its features. A companion addition to the @code{newtxmath} package
+provides a matching math package using STIX2 letters (Roman and Greek) with
+@code{newtxmath} symbols.")
+ (license (list license:silofl1.1 license:lppl1.3+))))
+
(define-public texlive-structmech
(package
(name "texlive-structmech")