summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 10:51:46 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:07:46 -0400
commit5f4e62b28b3e5a0331522cf45f833b1cb8dcfe50 (patch)
treeffe75d8d4fd3bcad557e00514a675b064c0498a4
parent0c8a0ce264eb9d9a2335485811afb2789f65a515 (diff)
gnu: Add texlive-ebong.
* gnu/packages/tex.scm (texlive-ebong): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e459415bf9..bc0a64bab0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11104,6 +11104,28 @@ optionally be replaced with graphics paths so that applications that do not
support SVG fonts are enabled to render the graphics properly.")
(license license:gpl3+)))
+(define-public texlive-ebong
+ (package
+ (name "texlive-ebong")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ebong/" "scripts/ebong/")
+ (base32
+ "0ivzr6d83ws7q00k71zdz1v25y88fhja1safc4jfvd45i58fccy7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ebong.py")))
+ (inputs (list python))
+ (home-page "https://ctan.org/pkg/ebong")
+ (synopsis "Utility for writing Bengali in Rapid Roman Format")
+ (description
+ "This package provides a tool (preprocessor) for writing your
+@code{pRaa-ne-r} ka-thaa in the Bengali langauage. It allows one to write the
+text in Rapid Roman Bangla and convert it to the BangTeX format by a Python
+program. All LaTeX markups are preserved in the target file.")
+ (license license:public-domain)))
+
(define-public texlive-eijkhout
(package
(name "texlive-eijkhout")