summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJake Leporte <jakeleporte@outlook.com>2023-03-05 19:30:26 -0600
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-21 21:44:54 -0400
commit608b26699fccde508c4459a9ab7e8b4637622300 (patch)
tree8f795084d400bf32bd5a2250ae685e3560da34f3
parent151be9ec766f82ef2439ce2cc95e04b7d0de3c91 (diff)
gnu: Add perl-pcsc.
* gnu/packages/perl.scm (perl-pcsc): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/perl.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 64b3efe4a4..3d9fa5ac83 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -89,6 +89,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages security-token)
#:use-module (gnu packages textutils)
#:use-module (gnu packages video)
#:use-module (gnu packages web)
@@ -12323,6 +12324,40 @@ As a convenience, the PIR module is an empty subclass of this one that is less
arduous to type for one-liners.")
(license license:asl2.0)))
+(define-public perl-pcsc
+ (package
+ (name "perl-pcsc")
+ (version "1.4.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/W/WH/WHOM/pcsc-perl-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "17f6i16jv6ci6459vh6y3sz94vgcvykjjszcl4xsykryakjvf8i7"))))
+ (build-system perl-build-system)
+ (arguments
+ (list
+ ;; The test suite is disabled because it requires access to a card
+ ;; reader with a card inserted.
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-dlopen
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "PCSCperl.h"
+ (("libpcsclite.so.1")
+ (search-input-file inputs
+ "/lib/libpcsclite.so.1"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list pcsc-lite))
+ (synopsis "Perl library for PC/SC")
+ (description
+ "This library allows communication with a smart card using PC/SC from a Perl
+script.")
+ (home-page "https://pcsc-perl.apdu.fr/")
+ (license license:gpl2+)))
+
(define-public perl-pod-constants
(package
(name "perl-pod-constants")