summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-10-25 00:50:57 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-25 01:06:09 +0200
commit634ce81e2a8609da6e013a66ce27b5aa91727ffe (patch)
tree0c9e84cb8c4f3adbe37f93197e5ef4d2b990a656
parent952ed957aa28d7659b6dfe5e360fbbbb04eea8df (diff)
gnu: python-robotframework: Update to 3.2.2.
The update of Pandas to 0.25.2 in commit 7a97a26d012da08fad4540eed99643f6306de423 broke the tests. * gnu/packages/python-xyz.scm (python-robotframework): Update to 3.2.2. [arguments]: In 'check' phase, set TZ and TZDIR. [native-inputs]: Add TZDATA-FOR-TESTS.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 96c29da207..fe30c6b829 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3675,7 +3675,7 @@ ecosystem, but can naturally be used also by other projects.")
(define-public python-robotframework
(package
(name "python-robotframework")
- (version "3.1.2")
+ (version "3.2.2")
;; There are no tests in the PyPI archive.
(source
(origin
@@ -3685,7 +3685,7 @@ ecosystem, but can naturally be used also by other projects.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "16gnxy0qinh8fhs0qvhff5z2xh49c3cqgm0d7bfjw120df6x7fym"))
+ (base32 "0if0h3myb9m3hgmn1phrhq8pfp89kfqsaq32vmfdjkyjdj7y59ds"))
(patches (search-patches
"python-robotframework-honor-source-date-epoch.patch"))))
(build-system python-build-system)
@@ -3702,12 +3702,23 @@ ecosystem, but can naturally be used also by other projects.")
(string-append doc "/libraries"))
#t)))
(replace 'check
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Some tests require timezone data. Otherwise, they
+ ;; look up /etc/localtime, which doesn't exist, and fail
+ ;; with:
+ ;;
+ ;; OverflowError: mktime argument out of range
+ (setenv "TZDIR"
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ (setenv "TZ" "Europe/Paris")
+
(invoke "python" "utest/run.py"))))))
(native-inputs
`(("python-invoke" ,python-invoke)
("python-rellu" ,python-rellu)
- ("python:tk" ,python "tk"))) ;used when building the HTML doc
+ ("python:tk" ,python "tk") ;used when building the HTML doc
+ ("tzdata" ,tzdata-for-tests)))
(outputs '("out" "doc"))
(home-page "https://robotframework.org")
(synopsis "Generic automation framework")