summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-01-29 21:08:08 +0800
committer宋文武 <iyzsong@gmail.com>2015-01-30 21:47:01 +0800
commit686e025d79e9747adb96c1d328c799539a2ec8c3 (patch)
tree123d24b533ab3ad9c5910cdb1dfa5f7eacc81250
parent241e122193e6eee900cab1f3a1caec2f90603560 (diff)
gnu: Add desktop-file-utils.
* gnu/packages/gnome.scm (desktop-file-utils): New variable.
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d8b9acf83b..c42092d28e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -313,6 +313,38 @@ Specification, the icon naming utility maps the icon names used by the
GNOME and KDE desktops to the icon names proposed in the specification.")
(license license:lgpl2.1+)))
+(define-public desktop-file-utils
+ (package
+ (name "desktop-file-utils")
+ (version "0.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.freedesktop.org/software/" name
+ "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1ianvr2a69yjv4rpyv30w7yjsmnsb23crrka5ndqxycj4rkk4dc4"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "http://www.freedesktop.org/wiki/Software/desktop-file-utils/")
+ (synopsis "Utilities for working with desktop entries")
+ (description
+ "This package contains a few command line utilities for working with
+desktop entries:
+
+desktop-file-validate: validates a desktop file and prints warnings/errors
+ about desktop entry specification violations.
+
+desktop-file-install: installs a desktop file to the applications directory,
+ optionally munging it a bit in transit.
+
+update-desktop-database: updates the database containing a cache of MIME types
+ handled by desktop files.")
+ (license license:gpl2+)))
+
(define-public gnome-icon-theme
(package
(name "gnome-icon-theme")