summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2024-05-12 22:30:25 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2024-05-12 23:22:43 +0200
commit6957a9c336347127addba223bcbeb115cac83e1a (patch)
tree38217115671c1707d3e5fdd6c82938d89c1f84bb
parent89cd778f6a45cd9b43a4dc1f236dcd0a87af955c (diff)
gnu: Add tree-sitter-kotlin.
* gnu/packages/tree-sitter.scm (tree-sitter-kotlin): New variable. Change-Id: Id29bf5097a4950bdc6a4509eeb7bb8c411064169
-rw-r--r--gnu/packages/tree-sitter.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index d271689fdb..d321609efb 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -709,3 +709,11 @@ which will be used as a snippet in origin."
"1.0.8"
;; Version 1.2.1 is most recent, but requires tree-sitter >0.21.0
#:repository-url "https://github.com/tlaplus-community/tree-sitter-tlaplus"))
+
+(define-public tree-sitter-kotlin
+ (tree-sitter-grammar
+ "kotlin" "Kotlin"
+ "0lqwjg778xy561hhf90c9m8zdjmv58z5kxgy0cjgys4xqsfbfri6"
+ "0.3.6"
+ #:repository-url "https://github.com/fwcd/tree-sitter-kotlin"
+ #:commit "0.3.6"))