summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 10:52:08 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:07:46 -0400
commit6bfc08543d8fa6f5dd63a16a58caf94a4f4e3579 (patch)
tree8a2a1e15725401ffbe9e72d25fd91e23da708163
parent5f4e62b28b3e5a0331522cf45f833b1cb8dcfe50 (diff)
gnu: Add texlive-ethiop.
* gnu/packages/tex.scm (texlive-ethiop): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc0a64bab0..18395543de 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11206,6 +11206,36 @@ an @file{.eps} file has anything except the origin for the lower-left of its
bounding box.")
(license license:public-domain)))
+(define-public texlive-ethiop
+ (package
+ (name "texlive-ethiop")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ethiop/"
+ "fonts/ofm/public/ethiop/"
+ "fonts/ovf/public/ethiop/"
+ "fonts/ovp/public/ethiop/"
+ "fonts/source/public/ethiop/"
+ "fonts/tfm/public/ethiop/"
+ "omega/ocp/ethiop/"
+ "omega/otp/ethiop/"
+ "source/latex/ethiop/"
+ "tex/latex/ethiop/")
+ (base32
+ "1852g96rjyrsky7mpfwlxgip11qmk800xcmqccs8cv51f5342qlq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/ethiop")
+ (synopsis "LaTeX macros and fonts for typesetting Amharic")
+ (description
+ "This package provides Ethiopian language support for the Babel package,
+including a collection of fonts and TeX macros for typesetting the characters
+of the languages of Ethiopia, with Metafont fonts based on EthTeX's. The
+macros use the Babel framework.")
+ (license license:gpl3+)))
+
(define-public texlive-expex-acro
(package
(name "texlive-expex-acro")