summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:26:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:26:45 +0100
commit6ca7d1a6159b3153cf64806dfe06f39516ae160a (patch)
tree14f3d37983c9a0602627b1c715123601feb06004
parent4e4aebde6a825310dd2018ed8717944ee3f2bf69 (diff)
gnu: go-github-com-hashicorp-hcl: Sort alphabetically.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-hcl): Sort alphabetically. Change-Id: I42cb5fc138757d32b0c7daf1c810d298d5d0d5f9
-rw-r--r--gnu/packages/golang-xyz.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5a2381eed2..461d67f8bc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1083,33 +1083,6 @@ while callers can implement logging with whatever backend is appropriate.")
wrapping errors and checking if an error contains another error.")
(license license:mpl2.0)))
-(define-public go-github-com-hashicorp-hcl
- (package
- (name "go-github-com-hashicorp-hcl")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hashicorp/hcl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0q6ml0qqs0yil76mpn4mdx4lp94id8vbv575qm60jzl1ijcl5i66"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/hashicorp/hcl"))
- (native-inputs
- (list go-github-com-davecgh-go-spew))
- (synopsis "Go implementation of HashiCorp Configuration Language V1")
- (description
- "This package contains the main implementation of the @acronym{HCL,
-HashiCorp Configuration Language}. HCL is designed to be a language for
-expressing configuration which is easy for both humans and machines to read.")
- (home-page "https://github.com/hashicorp/hcl")
- (license license:mpl2.0)))
-
(define-public go-github-com-hashicorp-hcl-v2
(package
(name "go-github-com-hashicorp-hcl-v2")
@@ -1280,6 +1253,33 @@ a collection of versions properly, handles prerelease/beta versions, can
increment versions.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-hcl
+ (package
+ (name "go-github-com-hashicorp-hcl")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/hcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q6ml0qqs0yil76mpn4mdx4lp94id8vbv575qm60jzl1ijcl5i66"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/hcl"))
+ (native-inputs
+ (list go-github-com-davecgh-go-spew))
+ (synopsis "Go implementation of HashiCorp Configuration Language V1")
+ (description
+ "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}. HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+ (home-page "https://github.com/hashicorp/hcl")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")