summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-01-05 14:30:47 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:22 -0500
commit6de717c4f4e08a0241e2e2f49b8d8c5820409e94 (patch)
treede3d87e01f651fd3d09316c8490b00708e113497
parentd8875d76555faf1a11f6838312bfe4b7f6121d2c (diff)
gnu: jemalloc: Build with large page size.
* gnu/packages/jemalloc.scm (jemalloc): Build with large page size. Change-Id: Ic813e7b0fe4c7ee79a1e703247abea77ad9d53f0 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/jemalloc.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 5e7facfd5e..b5fdd39921 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -62,6 +62,8 @@
;; https://github.com/jemalloc/jemalloc/issues/937
#~'("--disable-initial-exec-tls"
#$@(match (%current-system)
+ ("aarch64-linux"
+ (list "--with-lg-page=14"))
("powerpc-linux"
(list "CPPFLAGS=-maltivec"))
(_