summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:53:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:38 +0200
commit6e2e690d65ca47ecfb61fb52f70f4c3daf0b9902 (patch)
tree1d8118c22742ded87f932b480eb7a1d727070601
parentc404410645a2e4f29abf6f8a1e7acec708302832 (diff)
gnu: Add texlive-punk.
* gnu/packages/tex.scm (texlive-punk): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c1996cd5b8..e729df3cf6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21847,6 +21847,31 @@ as a result, some of the descriptions of limitations look rather quaint to
modern eyes.")
(license license:lppl)))
+(define-public texlive-punk
+ (package
+ (name "texlive-punk")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/punk/"
+ "fonts/source/public/punk/"
+ "fonts/tfm/public/punk/")
+ (base32
+ "0ncarqjmwrsiw65p7mr44gjy0h90q5hw5n4jb5y2fxr1kgbzmz1p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/punk")
+ (synopsis "Donald Knuth's Punk font")
+ (description
+ "This package provides a response to the assertion in a lecture that
+``typography tends to lag behind other stylistic changes by about 10 years''.
+Knuth felt it was (in 1988) time to design a replacement for his designs of
+the 1970s, and came up with the Punk font! The fonts are distributed as
+Metafont source. The package also offers LaTeX support for them, although
+@code{punk-latex} is a better choice.")
+ (license license:knuth)))
+
(define-public texlive-pythonhighlight
(package
(name "texlive-pythonhighlight")