summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-03 12:13:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-03 12:31:19 +0200
commit6ed46bf5159f6763f24785dd48dcf9bcf7d31015 (patch)
tree7e8722df5b613eda1342b5c3a687c709859b95ae
parent9a1093206e6f157f085dd24dc31f13367797e597 (diff)
gnu: emacs-scpaste: Update to 0.7.0.
* gnu/packages/emacs-xyz.scm (emacs-scpaste): Update to 0.7.0.
-rw-r--r--gnu/packages/emacs-xyz.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3045bb58d6..3b5ca53b08 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35865,32 +35865,30 @@ in other major modes. Links can be opened and edited like in Org mode.")
(license license:gpl3+)))
(define-public emacs-scpaste
- (let ((commit "cd4fa0aafecd839736e0b6cba68b4fc4d7045472")
- (revision "0"))
- (package
- (name "emacs-scpaste")
- (version "0.6.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~technomancy/scpaste")
- (commit commit)))
- (file-name (git-file-name name commit))
- (sha256
- (base32
- "1nvwbwl26z03963g9c82b3ggm39r95z1vp7c9qsa9mjm46dyq27w"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-htmlize))
- (home-page "https://git.sr.ht/~technomancy/scpaste")
- (synopsis "Emacs-based static HTML pastebin")
- (description "This library will place an HTML copy of a
+ (package
+ (name "emacs-scpaste")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~technomancy/scpaste")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hahk2m0cvky77h9p5zrfx0qcig4r3qyp9c1ji02kal64i9aib1s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-htmlize))
+ (home-page "https://git.sr.ht/~technomancy/scpaste")
+ (synopsis "Emacs-based static HTML pastebin")
+ (description "This library will place an HTML copy of a
buffer on an active webserver to which the user has SSH access.
It is similar in purpose to services such as Gist or Pastebin,
but is much simpler since it assumes the user has access to a
publicly-accessible HTTP server.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-company-reftex
(package