summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:08 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-20 08:54:11 -0500
commit7343bb8325c3ca9f252cdcafa06805ca20e97d83 (patch)
treea52eedaf2ff4de69f67c78812361c0fedd73a76f
parent4fb0b075e4c4fe50ed097dad38861de5b930162f (diff)
gnu: Add go-github-com-jaytaylor-html2text.
* gnu/packages/golang.scm (go-github-com-jaytaylor-html2text): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 58f8a8996f..2ed4c7a73c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10517,6 +10517,34 @@ using shell-style rules for quoting and commenting.")
email library.")
(license license:gpl3+)))
+(define-public go-github-com-jaytaylor-html2text
+ (package
+ (name "go-github-com-jaytaylor-html2text")
+ (version "0.0.0-20211105163654-bc68cce691ba")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaytaylor/html2text")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12ckgkp8xqgp0fh6019nwp4ssg2k1rv1a67cpk37ian4q5zrvppm"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/jaytaylor/html2text"
+ ;; Tests are broken: <https://github.com/jaytaylor/html2text/issues/53>
+ #:tests? #f))
+ (propagated-inputs (list go-golang-org-x-net
+ go-github-com-olekukonko-tablewriter
+ go-github-com-ssor-bom))
+ (home-page "https://github.com/jaytaylor/html2text")
+ (synopsis "Convert HTML emails to text")
+ (description
+ "The html2text package converts HTML emails to plain text, allowing
+text-only mail clients to display them.")
+ (license license:expat)))
+
(define-public go-github-com-creack-pty
(package
(name "go-github-com-creack-pty")