summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-03-06 16:31:02 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:28 +0000
commit7991eedd0393e0a90892ef27cf1eb9ea28eb0754 (patch)
treecd8bc432aa8c083099379e698da0825fbff49315
parent06d6f3debf0103e4d397f4fc7a5b88a9711fa973 (diff)
gnu: Add go-github-com-shirou-gopsutil-v3.
* gnu/packages/golang-xyz.scm (go-github-com-shirou-gopsutil-v3): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ibbfe76f0a56daf76fc4a4ecd844b445e9355a7ce
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fc1d2213de..28bd13018f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1139,6 +1139,34 @@ sensors).")
(home-page "https://github.com/shirou/gopsutil")
(license license:bsd-3)))
+(define-public go-github-com-shirou-gopsutil-v3
+ (package
+ (inherit go-github-com-shirou-gopsutil)
+ (name "go-github-com-shirou-gopsutil-v3")
+ (version "3.24.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xlfcx6giqaxdah2m02q2i8ynwlzar953wr8wqx1j3004xdgaivd"))))
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/shirou/gopsutil"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'remove-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ ;; host_test.go tries to access files such as
+ ;; /var/run/utmp that do not exist in the build
+ ;; environment.
+ (string-append "src/" import-path "/host/host_test.go")))))))))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")