summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-19 10:13:50 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-19 10:25:16 +0100
commit801b5c7c2fc5cc268a2818e1eec12abfa9a94f4d (patch)
tree8d8e8a5a97904024b289723ab73cedb6fe205fc0
parentb4d4e3252ebd15e90085ce022445ac4a2e3120e1 (diff)
gnu: emacs-flymake-proselint: Update to 0.3.0.
* gnu/packages/emacs-xyz.scm (emacs-flymake-proselint): Update to 0.3.0.
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 32 insertions, 33 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5997dea6a9..c1de30358c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6923,39 +6923,38 @@ files which are intended to be packages.")
(license license:gpl3+)))
(define-public emacs-flymake-proselint
- (let ((commit "6a99865c7ac6474b8c5d1f9a1ae2384667f06d36")
- (revision "0"))
- (package
- (name "emacs-flymake-proselint")
- (version (git-version "0.2.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~manuel-uberti/flycheck-proselint")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "028ilp9h22rlawlh5ydiykvi8pryyknwi019sjyxkk2h0fza9jan"))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "flymake-proselint.el"
- (("\"proselint\"")
- (string-append
- "\"" (search-input-file inputs "/bin/proselint") "\""))))))))
- (propagated-inputs
- (list emacs-flycheck))
- (inputs
- (list python-proselint))
- (home-page "https://git.sr.ht/~manuel-uberti/flycheck-proselint")
- (synopsis "Flymake backend for @code{proselint}")
- (description "This package adds support for @code{proselint} in Flymake.")
- (license license:gpl3+))))
+ (let ((commit "9c68ee881f18f554f0ab5bbf5bee1a4b753d792b"))
+ (package
+ (name "emacs-flymake-proselint")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~manuel-uberti/flycheck-proselint")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n8i17il2nfazw3d9kza2r7py61dgdr7kqmg0s1vhrk86qq39669"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "flymake-proselint.el"
+ (("\"proselint\"")
+ (string-append
+ "\"" (search-input-file inputs "/bin/proselint") "\""))))))))
+ (propagated-inputs
+ (list emacs-flycheck))
+ (inputs
+ (list python-proselint))
+ (home-page "https://git.sr.ht/~manuel-uberti/flycheck-proselint")
+ (synopsis "Flymake backend for @code{proselint}")
+ (description "This package adds support for @code{proselint} in Flymake.")
+ (license license:gpl3+))))
(define-public emacs-elisp-demos
(package