summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:45:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:22:50 +0200
commit805039426d11e6cddbba6144e69a6ebbf1e56b91 (patch)
tree373f6a67b43aaee086320f6b57ee9b8f8ef73ac1
parent383e9a4b0d49e321235fc5098ed8d76adfc37d1a (diff)
gnu: Add texlive-arphic-ttf.
* gnu/packages/tex.scm (texlive-arphic-ttf): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index aa8493a439..dbedf2092a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2353,6 +2353,27 @@ LuaLaTeX are provided by the @code{arphic-ttf} package.")
;; non-GNU FTP site, using the license below.
(license license:arphic-1999)))
+(define-public texlive-arphic-ttf
+ (package
+ (name "texlive-arphic-ttf")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/arphic-ttf/"
+ "fonts/truetype/public/arphic-ttf/")
+ (base32
+ "141hsz7lhqpbz3k10kl57bg21yslrb562alk1a6q129i56zb7jby")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/arphic-ttf")
+ (synopsis "TrueType version of Chinese Arphic fonts")
+ (description
+ "This package provides TrueType versions of the Chinese Arphic fonts for
+use with XeLaTeX and LuaLaTeX. Type1 versions of these fonts, for use with
+pdfLaTeX and the @code{cjk} package, are provided by the @code{arphic}
+package.")
+ (license license:arphic-1999)))
+
(define-public texlive-ascii-chart
(package
(name "texlive-ascii-chart")