summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMilkey Mouse <milkeymouse@meme.institute>2024-01-20 17:39:53 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:20 -0500
commit8219ab0443129c71eef83ee4bd3aae0a0a12b6f9 (patch)
tree7b57fed396d5b34f3b587496b554eafcc3a082ce
parent76a5553b22ebcf8daab9675cd997cdd696dfb4d8 (diff)
gnu: rust: Add profiling support.
* gnu/packages/rust.scm (rust-1.52) [phases] <unpack-profiler-rt, enable-profiling>: New phases. Change-Id: Iecb4aef518e52f71ff7f539778bf0341288a3458
-rw-r--r--gnu/packages/rust.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index e7d61f3729..c8ba29ea0f 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -982,11 +982,24 @@ safety and thread safety guarantees.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "src/bootstrap/builder.rs"
- ((" = rpath.*" all)
- (string-append all
- " "
- "rustflags.arg(\"-Clink-args=-Wl,-rpath="
- out "/lib\");\n"))))))
+ ((" = rpath.*" all)
+ (string-append all
+ " "
+ "rustflags.arg(\"-Clink-args=-Wl,-rpath="
+ out "/lib\");\n"))))))
+ (add-after 'unpack 'unpack-profiler-rt
+ ;; Copy compiler-rt sources to where libprofiler_builtins looks
+ ;; for its vendored copy. Keep the clang-runtime version in
+ ;; sync with the LLVM version used to build Rust.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir-p "src/llvm-project/compiler-rt")
+ (invoke "tar" "-xf" #$(package-source clang-runtime-15)
+ "-C" "src/llvm-project/compiler-rt" "--strip-components=1")))
+ (add-after 'enable-codegen-tests 'enable-profiling
+ (lambda _
+ (substitute* "config.toml"
+ (("^profiler =.*$") "")
+ (("\\[build\\]") "\n[build]\nprofiler = true\n"))))
(add-after 'configure 'add-gdb-to-config
(lambda* (#:key inputs #:allow-other-keys)
(let ((gdb (assoc-ref inputs "gdb")))
@@ -1002,7 +1015,7 @@ safety and thread safety guarantees.")
(number->string (parallel-job-count))
"1"))))
(invoke "./x.py" job-spec "build"
- "library/std" ;rustc
+ "library/std" ;rustc
"src/tools/cargo"
"src/tools/clippy"
"src/tools/rust-analyzer"