summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-12-04 22:17:09 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-04 23:08:20 +0100
commit84424ae3c91c82c5d1b10728ba131b07d3acbb7a (patch)
treedd3bd8021b4f8abeef0cc5a9307bfa9f94d48e3f
parentcbab7c1b3c0aa691bf407a7daf168ea790163dde (diff)
gnu: libapparmor: Restrict supported systems to GNU/Linux.
* gnu/packages/apparmor.scm (libapparmor)[supported-systems]: New field.
-rw-r--r--gnu/packages/apparmor.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/apparmor.scm b/gnu/packages/apparmor.scm
index 9b2019d296..ddbd9eb7a9 100644
--- a/gnu/packages/apparmor.scm
+++ b/gnu/packages/apparmor.scm
@@ -109,7 +109,10 @@ AppArmor supplements the traditional Unix discretionary access control (DAC)
model by providing mandatory access control (MAC). It has been included in
the mainline Linux kernel since version 2.6.36 and its development has been
supported by Canonical since 2009.")
- (license license:lgpl2.1)))
+ (license license:lgpl2.1)
+ (supported-systems (filter (lambda (system)
+ (string-suffix? "-linux" system))
+ %supported-systems))))
(define-public apparmor
(let ((base libapparmor))