summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:35 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:37 +0100
commit880310007288f9901514ae779809c7b4915dfcc9 (patch)
treec8ee7269c9b225a84dda0cb87c77b283dfc1a044
parent7068bb376fb84ff62c0ed488f1daaf30c2322a9c (diff)
gnu: Add python-pyfma.
* gnu/packages/python-science.scm (python-pyfma): New variable. Change-Id: I354d3d56f2799c8c9ac9b868fcacbf88dcc5c25d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index e836235a6b..604ef6d08e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1891,6 +1891,31 @@ Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+(define-public python-pyfma
+ (package
+ (name "python-pyfma")
+ (version "0.1.6")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/nschloe/pyfma")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12i68jj9n1qj9phjnj6f0kmfhlsd3fqjlk9p6d4gs008azw5m8yn"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy))
+ (native-inputs (list pybind11 python-pytest))
+ (home-page "https://github.com/nschloe/pyfma")
+ (synopsis "Fused multiply-add for Python")
+ (description "@code{pyfma} provides an implementation of fused
+multiply-add which computes @code{(x*y) + z} with a single rounding.
+This is useful for dot products, matrix multiplications, polynomial
+evaluations (e.g., with Horner's rule), Newton's method for evaluating
+functions, convolutions, artificial neural networks etc.")
+ (license license:expat)))
+
(define-public python-pydicom
(package
(name "python-pydicom")