summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-15 20:16:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-24 22:24:38 +0000
commit884bddc26cd2136abd3f90792de519a4ddbc9b6e (patch)
tree139f763f209dd2011db27f9c3a5ab9b92e71dd96
parent324bc1ea8fa022f67f6f85636baa738de99add33 (diff)
gnu: python-skyfield: Update to 1.47.
* gnu/packages/astronomy.scm (python-skyfield): Update to 1.47. [inputs]: Remove python-certifi, python-jplephem, python-numpy, and python-sgp4. [propagated-inputs]: Add python-certifi, python-jplephem, python-numpy, and python-sgp4. Change-Id: If5a9a47077edcebe83449c4c54a49189dea61c5a
-rw-r--r--gnu/packages/astronomy.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 874e9e07c4..30f99dea5f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4485,20 +4485,23 @@ astronomical images, especially when there is no WCS information available.")
(define-public python-skyfield
(package
(name "python-skyfield")
- (version "1.46")
+ (version "1.47")
(source
(origin
(method url-fetch)
(uri (pypi-uri "skyfield" version))
(sha256
- (base32 "1r4kpsh1pa4h3diyxy3gyapp0rykfjdqmn5w348a2ck2qkdlx997"))))
+ (base32 "0272pwk88csmrrl44fc4l52agd68pkg4zbmdhs7gliq5q9wf3hrs"))))
(build-system python-build-system)
(arguments
- ;; NOTE: (Sharlatan-20210207T163305+0000): tests depend on custom test
- ;; framework https://github.com/brandon-rhodes/assay
+ ;; XXX: Tests depend on custom test framework
+ ;; https://github.com/brandon-rhodes/assay
`(#:tests? #f))
- (inputs
- (list python-certifi python-jplephem python-numpy python-sgp4))
+ (propagated-inputs
+ (list python-certifi
+ python-jplephem
+ python-numpy
+ python-sgp4))
(home-page "https://rhodesmill.org/skyfield/")
(synopsis "Astronomy for Python")
(description