summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-09-25 16:28:39 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-25 19:09:44 +0200
commit89c4273fbf1d436bde474a53d1c25a52378f793a (patch)
tree4e5b28bd65c72717799e02925b4e3eab24b56e1b
parent2d141896ec48649f2a3048f679cf64798f26b788 (diff)
gnu: emacs-pdf-tools: Fix build with native compilation.
* gnu/packages/emacs-xyz.scm (emacs-pdf-tools)[#:phases]: Add ‘emacs-add-install-to-native-load-path’ between ‘emacs-expand-load-path’ and ‘emacs-install’. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e48757ee69..b6e64f812d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4047,7 +4047,9 @@ during idle time, while Emacs is doing nothing else.")
("pdf-tools-handle-upgrades" '()))))
(add-after 'emacs-patch-variables 'emacs-expand-load-path
(assoc-ref emacs:%standard-phases 'expand-load-path))
- (add-after 'emacs-expand-load-path 'emacs-install
+ (add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
+ (assoc-ref emacs:%standard-phases 'add-install-to-native-load-path))
+ (add-after 'emacs-add-install-to-native-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
(add-after 'emacs-install 'emacs-build
(assoc-ref emacs:%standard-phases 'build))