summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-08 14:02:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-08 17:13:46 +0200
commit8b0500729754e208bff983563bfe60836de9f30b (patch)
tree8546a1509daeec1d7622f77049f063b2a8a165fb
parentd79c88e8809d2079452fd276bf4d17eb16636ff9 (diff)
gnu: colord-minimal: Skip tests on big-endian systems.
* gnu/packages/gnome.scm (colord-minimal)[arguments]: Disable tests when building on a big-endian system. Change-Id: I6d1ba215894175e75ed4a3171ad3c54cb12653cd
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d14651c792..a0710aa78a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5583,6 +5583,9 @@ file.")
"-Dlocalstatedir=/var"
"-Dman=false"
"-Dsystemd=false") ;no systemd
+ ;; Apparently the tests are known to fail on big-endian systems.
+ #:tests? (not (or (%current-target-system)
+ (not (target-little-endian?))))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'disable-problematic-tests