summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:02 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-19 23:45:29 -0500
commit8cef05bab6251978018ccab7bb44883676ce8f6c (patch)
treed1825724eb22607c57649371bc0a9411d4d9e284
parentac09fcb955e9358c330d728693759ca1a2e20542 (diff)
gnu: Add go-github-com-kyoh86-xdg.
* gnu/packages/golang.scm (go-github-com-kyoh86-xdg): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..28730f1dee 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10532,6 +10532,30 @@ email library.")
of the current user.")
(license license:expat)))
+(define-public go-github-com-kyoh86-xdg
+ (package
+ (name "go-github-com-kyoh86-xdg")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kyoh86/xdg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a5nz53fdz1c2qvwlf2dpjdd72nxri95i6q4b07c37kiipgaxncn"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/kyoh86/xdg"))
+ (home-page "https://github.com/kyoh86/xdg")
+ (synopsis "XDG base directories for Go")
+ (description
+ "The xdg package provides lightweight helper functions in Go to get
+config, data and cache directories according to the XDG Base Directory
+Specification.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar