summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-31 21:01:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:16:57 +0100
commit903117947bfe74be402d8200dccbc7be1e0f0aa2 (patch)
tree31433b336a04d92343d218475f7ce1d5ecb2c1f9
parent8a3a91117c080668288db6a5660f52ab4d87b783 (diff)
gnu: go-github-com-schollz-progressbar-v3: Adjust inputs.
* gnu/packages/golang-xyz.scm (go-github-com-schollz-progressbar-v3): Adjust inputs. [propagated-inputs]: Remove go-github-com-davecgh-go-spew, go-github-com-mattn-go-isatty, and go-github-com-stretchr-testify. [native-inputs]: Add go-github-com-stretchr-testify. Change-Id: I8a1e24d6570ce36812d08e196f415b81e8ec7bda
-rw-r--r--gnu/packages/golang-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c62fab949f..9b0f67de6f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2077,12 +2077,11 @@ Metrics library.")
;; The full test suite requires Internet access, so only
;; run the short tests.
(invoke "go" "test" "-test.short" import-path)))))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
(propagated-inputs
- (list go-github-com-davecgh-go-spew
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-mitchellh-colorstring
- go-github-com-stretchr-testify
go-golang-org-x-term))
(home-page "https://github.com/schollz/progressbar")
(synopsis "Simple command-line interface (CLI) progress bar")