summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:07:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:45 +0200
commit91c9b83fde3ad4f1abbf0cc7cc6223bf75274edb (patch)
tree118ffcefe267998fd0f39198801fc7789560b1b2
parent8a13eabf7db8be62d9b16608140427104320442b (diff)
gnu: Add texlive-texdate.
* gnu/packages/tex.scm (texlive-texdate): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e305fc74ee..945276dec7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3817,6 +3817,31 @@ transformations of EPS files, prepress preparation, color separation, mirror,
etc.")
(license license:public-domain)))
+(define-public texlive-texdate
+ (package
+ (name "texlive-texdate")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/texdate/"
+ "source/generic/texdate/"
+ "tex/generic/texdate/")
+ (base32
+ "0knssay50rm8pbksph20hhfbpwwby3a9pswvxyq63imn5qppz2dp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/texdate")
+ (synopsis "Date printing, formatting, and manipulation in TeX")
+ (description
+ "TeX and LaTeX provide few facilities for dates by default, though many
+packages have filled this gap. This package fills it, as well, with a pure
+TeX-primitive implementation. It can print dates, advance them by numbers of
+days, weeks, or months, determine the weekday automatically, and print them
+in (mostly) arbitrary format. It can also print calendars (monthly and
+yearly) automatically, and can be easily localized for non-English
+languages.")
+ (license license:lppl1.3c)))
+
(define-public texlive-lcdftypetools
(package
(name "texlive-lcdftypetools")