summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 16:57:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 18:03:44 +0100
commit92793c7b0287558becefeaa4832ebcb16e34a243 (patch)
tree7db01b13d3891692647b2d22e0e99cc187259768
parent7730b7179c615319cf038f4d83939dc9bbe7b750 (diff)
gnu: gitolite: Update phase style.
* gnu/packages/version-control.scm (gitolite): Substitute INVOKE for SYSTEM* and end phases with #t.
-rw-r--r--gnu/packages/version-control.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index f6b346fff8..209df2bb12 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -958,7 +958,8 @@ also walk each side of a merge and test those changes individually.")
;; This works because gitolite-shell is in the PATH.
(substitute* "src/triggers/post-compile/ssh-authkeys"
(("\\$glshell \\$user")
- "gitolite-shell $user")))))
+ "gitolite-shell $user"))
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((output (assoc-ref outputs "out"))
@@ -966,7 +967,7 @@ also walk each side of a merge and test those changes individually.")
(bindir (string-append output "/bin")))
(mkdir-p sharedir)
(mkdir-p bindir)
- (system* "./install" "-to" sharedir)
+ (invoke "./install" "-to" sharedir)
;; Create symlinks for executable scripts in /bin.
(for-each (lambda (script)
(symlink (string-append sharedir "/" script)