summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-13 01:12:32 -0500
committer宋文武 <iyzsong@member.fsf.org>2023-01-29 15:19:03 +0800
commit962ba701090f0dd3da67c353bb917eb0742602a7 (patch)
tree49b838a6c60c587f3a416486a5554afce8579550
parente225dbcb1ddee6c0d9fd006bc76db747da853ca2 (diff)
gnu: python-responses: Update to 0.22.0.
* gnu/packages/python-web.scm (python-responses): Update to 0.22.0. [arguments]: Enable tests. [native-inputs]: Add python-pytest, python-pytest-asyncio, and python-pytest-httpserver. [inputs]: Add python-types-toml. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ac0fb6f8a7..20e57db980 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3571,22 +3571,31 @@ Python.")
(define-public python-responses
(package
(name "python-responses")
- (version "0.10.6")
+ (version "0.22.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "responses" version))
(sha256
(base32
- "147pacwkkqy3qf3hr33fnl1xbzgw0zsm3qppvvy9qhq8h069qbah"))))
+ "0bhhffwl0zqin4xc89nc97ynzr7l3j4b8rjqk9w9flnj2cmcnsir"))))
(build-system python-build-system)
(arguments
- `(;; Test suite is not distributed:
- ;; https://github.com/getsentry/responses/issues/38
- #:tests? #f))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
(native-inputs
- (list python-mock))
+ (list python-mock
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-httpserver))
(propagated-inputs
- (list python-requests python-cookies python-six))
+ (list python-requests
+ python-cookies
+ python-six
+ python-types-toml))
(home-page "https://github.com/getsentry/responses")
(synopsis "Utility for mocking out the `requests` Python library")
(description "A utility library for mocking out the `requests` Python