summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-19 20:51:13 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-19 20:51:13 +0200
commit96c78878645f33b64b4b60fe8e1399c902b7facd (patch)
tree6fef0f4ec74583b33987eef8d349a652c7008ddc
parent72fe3c0a35f04a6616c17228953a20861ce9b690 (diff)
gnu: gnome-todo: Update to "Endeavour" 42.0.
* gnu/packages/gnome.scm (gnome-todo): Deprecate and rename to... (endeavour): ... this. [source]: Use git origin. * gnu/packages/patches/gnome-todo-libportal.patch: Deleted file. * gnu/local.mk (dist_patch_DATA): Update accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm20
-rw-r--r--gnu/packages/patches/gnome-todo-libportal.patch54
3 files changed, 11 insertions, 64 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0fe6ae4c0b..238fb72bc5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1219,7 +1219,6 @@ dist_patch_DATA = \
%D%/packages/patches/gnome-online-miners-tracker-3.patch \
%D%/packages/patches/gnome-settings-daemon-gc.patch \
%D%/packages/patches/gnome-session-support-elogind.patch \
- %D%/packages/patches/gnome-todo-libportal.patch \
%D%/packages/patches/gnome-tweaks-search-paths.patch \
%D%/packages/patches/gnupg-CVE-2022-34903.patch \
%D%/packages/patches/gnupg-default-pinentry.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8a49040f4..9229abb41d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10252,19 +10252,18 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
desktop. It supports multiple calendars, month, week and year view.")
(license license:gpl3+)))
-(define-public gnome-todo
+(define-public endeavour
(package
- (name "gnome-todo")
- (version "41.0")
+ (name "endeavour")
+ (version "42.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major version) "/"
- name "-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/World/Endeavour")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1r94880d4khbjhhfnhaba3y3d4hv2bri82rzfzxn27s5iybpqras"))
- (patches (search-patches "gnome-todo-libportal.patch"))))
+ "0d6by7aq8db35zavzvckcxxxcdi6qnv0mkjndhb0syc8ih15dpak"))))
(build-system meson-build-system)
(arguments
(list
@@ -10309,6 +10308,9 @@ desktop. It supports multiple calendars, month, week and year view.")
to perfectly fit the GNOME desktop.")
(license license:gpl3+)))
+(define-public gnome-todo
+ (deprecated-package "gnome-todo" endeavour))
+
(define-public gnome-dictionary
(package
(name "gnome-dictionary")
diff --git a/gnu/packages/patches/gnome-todo-libportal.patch b/gnu/packages/patches/gnome-todo-libportal.patch
deleted file mode 100644
index 380c628592..0000000000
--- a/gnu/packages/patches/gnome-todo-libportal.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 3e1f4da8c0e536c09ffaf3b43fe2eb5dc17cc23e Mon Sep 17 00:00:00 2001
-From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
-Date: Thu, 18 Nov 2021 19:46:13 -0300
-Subject: [PATCH] flatpak: Adjust to libportal changes
-
----
- build-aux/flatpak/org.gnome.Todo.json | 3 +++
- src/plugins/background/gtd-plugin-background.c | 2 +-
- src/plugins/background/meson.build | 2 +-
- 3 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/build-aux/flatpak/org.gnome.Todo.json b/build-aux/flatpak/org.gnome.Todo.json
-index 034e200c..44b83d66 100644
---- a/build-aux/flatpak/org.gnome.Todo.json
-+++ b/build-aux/flatpak/org.gnome.Todo.json
-@@ -143,6 +143,9 @@
- {
- "name" : "libportal",
- "buildsystem" : "meson",
-+ "config-opts" : [
-+ "-Dbackends=gtk4"
-+ ],
- "sources" : [
- {
- "type" : "git",
-diff --git a/src/plugins/background/gtd-plugin-background.c b/src/plugins/background/gtd-plugin-background.c
-index cf48786c..f64d07aa 100644
---- a/src/plugins/background/gtd-plugin-background.c
-+++ b/src/plugins/background/gtd-plugin-background.c
-@@ -28,7 +28,7 @@
- #include <gtk/gtk.h>
-
- #include <libportal/portal.h>
--#include <libportal/portal-gtk4.h>
-+#include <libportal-gtk4/portal-gtk4.h>
-
- #define AUTOSTART_NOTIFICATION_ID "Gtd::BackgroundPlugin::autostart_notification"
- #define AUTOSTART_NOTIFICATION_TIMEOUT 3 /* seconds */
-diff --git a/src/plugins/background/meson.build b/src/plugins/background/meson.build
-index a671a4f3..59d3635f 100644
---- a/src/plugins/background/meson.build
-+++ b/src/plugins/background/meson.build
-@@ -1,7 +1,7 @@
- plugins_ldflags += ['-Wl,--undefined=gtd_plugin_background_register_types']
-
- plugins_deps += [
-- dependency('libportal'),
-+ dependency('libportal-gtk4'),
- ]
-
- plugins_sources += files(
---
-GitLab
-