summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:06:15 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:07:47 -0400
commit9a6786dc44b16878d8c922438144f87446609709 (patch)
treef5f339fb9e92e4916bd962b6c2eccf70a155b9c7
parent6cbe16cbeaf6765e8b1d5c2e43b1ac56a752e7de (diff)
gnu: Add texlive-fonts-tlwg.
* gnu/packages/tex.scm (texlive-fonts-tlwg): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a8656e293..55d8dbc2e3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11643,6 +11643,35 @@ otc) into individual fonts.
@end itemize")
(license license:gpl2)))
+(define-public texlive-fonts-tlwg
+ (package
+ (name "texlive-fonts-tlwg")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/fonts-tlwg/"
+ "fonts/afm/public/fonts-tlwg/"
+ "fonts/enc/dvips/fonts-tlwg/"
+ "fonts/map/dvips/fonts-tlwg/"
+ "fonts/opentype/public/fonts-tlwg/"
+ "fonts/tfm/public/fonts-tlwg/"
+ "fonts/type1/public/fonts-tlwg/"
+ "fonts/vf/public/fonts-tlwg/"
+ "source/fonts/fonts-tlwg/"
+ "tex/latex/fonts-tlwg/")
+ (base32
+ "19g1ksxsidf6cpcxm3knbbfpjw6jsfq2acy99cgmsy7jn33k253b")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fonts-tlwg")
+ (synopsis "Thai fonts for LaTeX from TLWG")
+ (description
+ "This package provides a collection of Thai fonts, supplied as FontForge
+sources, and with LaTeX @file{.fd} files.")
+ (license (list license:gpl2+
+ license:lppl1.3+
+ (license:x11-style "file://source/fonts/fonts-tlwg/COPYING")))))
+
(define-public texlive-fontware
(package
(name "texlive-fontware")