summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:01:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:01:16 +0200
commit9ad858a7b469f31715e0f0ce6609a9dc79329585 (patch)
treecd2438086a3f0b5e0f4494b295d9814cafa9db91
parent5dc47ab13c8606bb09c44bb200de76e9ce38c703 (diff)
gnu: Add texlive-bxjatoucs.
* gnu/packages/tex.scm (texlive-bxjatoucs): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5556ea3f7a..ea9e857913 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3384,6 +3384,29 @@ paragraphs or lines are treated specially. This package adjusts the position
of parentheses accordingly.")
(license license:expat)))
+(define-public texlive-bxjatoucs
+ (package
+ (name "texlive-bxjatoucs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/bxjatoucs/"
+ "fonts/tfm/public/bxjatoucs/"
+ "tex/latex/bxjatoucs/")
+ (base32
+ "1032lfp9qy4arzy06s5hkqlva7y182763wxfdql93yn68hcn85vd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bxjatoucs")
+ (synopsis "Convert Japanese character code to Unicode")
+ (description
+ "This package is meant for macro or package developers: it provides
+function-like macros that convert a character code value in one of several
+Japanese encodings to a Unicode value. Supported source encodings are:
+ISO-2022-JP (jis), EUC-JP (euc), Shift_JIS (sjis), and the Adobe-Japan1 glyph
+set.")
+ (license license:expat)))
+
(define-public texlive-bytefield
(package
(name "texlive-bytefield")