summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-23 17:33:15 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:17 +0100
commita28d646b635a3515135265aef0a4979abe24fe34 (patch)
treed8bff777d6ff10dce3603094b981970ef6aa3244
parentd547ce5e70b0bbd1ea33471c7d0029f5ae3e49f5 (diff)
gnu: Add viridis.
* gnu/packages/statistics.scm (r-viridis): New variable.
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 84f64d033b..fefb71751c 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1887,3 +1887,29 @@ also some vector-based methods, e.g. @code{binMeans()}, @code{madDiff()} and
memory usage.")
(license license:artistic2.0)))
+(define-public r-viridis
+ (package
+ (name "r-viridis")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "viridis" version))
+ (sha256
+ (base32
+ "0zz9i874s1fwhl9bcbiprlzaz7zsy1rj6c729zn3k525d63qbnj7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)))
+ (home-page "https://github.com/sjmgarnier/viridis")
+ (synopsis "Matplotlib default color map")
+ (description
+ "This package is a port of the new @url{matplotlib,
+http://matplotlib.org/} color maps (@code{viridis}--the default--,
+@code{magma}, @code{plasma}, and @code{inferno}) to R. These color maps are
+designed in such a way that they will analytically be perfectly
+perceptually-uniform, both in regular form and also when converted to
+black-and-white. They are also designed to be perceived by readers with the
+most common form of color blindness.")
+ (license license:x11)))
+