summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-29 13:00:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:52:00 +0000
commita5cf84ded9452c7704290741c18b4c9181ed0ae2 (patch)
tree8d7f0e529b13244a00a3cbb01c39cc2a8344c135
parent691a732cfdc823ec6afaec500cae980e4f6b248d (diff)
gnu: Add python-sunpy-soar.
* gnu/packages/astronomy.scm (python-sunpy-soar): New variable. Change-Id: I6e7dd8cb7380df396720fda13f549858d2be440d
-rw-r--r--gnu/packages/astronomy.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d4c731a797..f6b58a5a87 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2705,6 +2705,50 @@ python_files = test_*.py"))))))))
SolarSoft data analysis environment.")
(license license:bsd-2)))
+(define-public python-sunpy-soar
+ (package
+ (name "python-sunpy-soar")
+ (version "1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sunpy-soar" version))
+ (sha256
+ (base32 "0pb7dr06n20hdhlqf8npb4j1qb5034cgwqi3iciqdi1wxyy5pjc6"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; Disabe tests requireing network access.
+ #~(list "-k" (string-append
+ "not test_search"
+ " and not test_search_low_latency"
+ " and not test_insitu_search"
+ " and not test_no_results"
+ " and not test_no_instrument"
+ " and not test_download_path"
+ " and not test_search_soop"
+ " and not test_when_soar_provider_passed"
+ " and not test_when_sdac_provider_passed"
+ " and not test_when_wrong_provider_passed"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home-env
+ (lambda _
+ ;; Tests require HOME to be set.
+ ;; Permission denied: '/homeless-shelter'
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-sunpy))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://docs.sunpy.org/projects/soar")
+ (synopsis "Solar Orbiter Archive plugin for SunPy")
+ (description
+ "This package provides a @code{sunpy} FIDO plugin for accessing data in the
+@acronym{Solar Orbiter Archive, SOAR}.")
+ (license license:bsd-2)))
+
(define-public python-astral
(package
(name "python-astral")