summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:59:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:46 +0200
commita6325c7ae9289606774989ca9c264f5ba1872c79 (patch)
treed373eeda1b2eb62c090de10d4cfe11d0c6997e01
parent22fafc2f8cadda19612b6c185e6eb333df14f97e (diff)
gnu: Add texlive-stix.
* gnu/packages/tex.scm (texlive-stix): New variable.
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 79c25aaa65..c0d15b5ba7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23950,6 +23950,44 @@ provides a matching math package using STIX2 letters (Roman and Greek) with
@code{newtxmath} symbols.")
(license (list license:silofl1.1 license:lppl1.3+))))
+(define-public texlive-stix
+ (package
+ (name "texlive-stix")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/stix/"
+ "fonts/enc/dvips/stix/"
+ "fonts/map/dvips/stix/"
+ "fonts/opentype/public/stix/"
+ "fonts/tfm/public/stix/"
+ "fonts/type1/public/stix/"
+ "fonts/vf/public/stix/"
+ "source/fonts/stix/"
+ "tex/latex/stix/")
+ (base32
+ "1ixxglx4azdnppiqhlkgyahj9a67zamljzv98n6hycp7y6jbd1x0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:tex-format "latex"
+ ;; FIXME: I cannot build this package from source.
+ #:phases #~(modify-phases %standard-phases (delete 'build))))
+ (native-inputs
+ (list (texlive-updmap.cfg
+ (list texlive-accents
+ texlive-caption
+ texlive-enumitem
+ texlive-fonttable
+ texlive-hypdoc))))
+ (home-page "https://ctan.org/pkg/stix")
+ (synopsis "OpenType Unicode maths fonts")
+ (description
+ "The STIX fonts are a suite of unicode OpenType fonts containing
+a complete set of mathematical glyphs. This package is considered obsolete.
+See @code{stix2-otf} and @code{stix2-type1} instead.")
+ (license (list license:silofl1.1 license:lppl1.3+))))
+
(define-public texlive-structmech
(package
(name "texlive-structmech")