summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-27 23:14:46 +0100
committerChristopher Baines <mail@cbaines.net>2023-11-05 18:09:35 +0000
commita8c1c9869093ca8b2cfae85f1c1186f6c8a4754a (patch)
tree23678d01c338d310dd286bc071957af62514bee2
parente7b315216af2d77b62532d525ae5160cbfd2835c (diff)
gnu: python-spherical-geometry: Simplify package.
* gnu/packages/astronomy.scm (python-spherical-geometry): [arguments]{phases}<preparations>: Switch to SETUPTOOLS_SCM_PRETEND_VERSION evnar instead modifying setup.py. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 22d6db984b..b69ba4d96a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2611,12 +2611,7 @@ of axis order, spatial projections, and spectral units that exist in the wild.
#~(modify-phases %standard-phases
(add-after 'unpack 'preparations
(lambda _
- ;; Fixing: setuptools-scm was unable to detect version for ...
- (substitute* "setup.py"
- (("use_scm_version=True")
- (format #f "version=~s" #$version))
- (("setup_requires=\\['setuptools_scm'\\],.*")
- ""))
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
;; Use our own libraries in place of bundles.
(setenv "USE_SYSTEM_QD" "1"))))))
(native-inputs