summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:33 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:24 -0500
commitab7511ad0d29c74e464087e67081cc87836a9c09 (patch)
tree08925afab2130bba00514a6e5d59d3af8553d756
parentba8babd9e74ab5692cfccc32f7dbafe9506a5002 (diff)
gnu: go-github-com-hjson-hjson-go: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-hjson-hjson-go): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/networking.scm: Add (gnu packages golang-web) module. * gnu/packages/uucp.scm: As above. Change-Id: If1ba5e4d866ce74fa35ae9126c6ba4cd0b149dab
-rw-r--r--gnu/packages/golang-web.scm24
-rw-r--r--gnu/packages/golang.scm24
-rw-r--r--gnu/packages/networking.scm1
-rw-r--r--gnu/packages/uucp.scm1
4 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 96873f020c..4771657add 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020 raingloom <raingloom@riseup.net>
;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
@@ -757,6 +758,29 @@ sessions, flash messages, custom backends, and more.")
protocol.")
(license license:bsd-2)))
+(define-public go-github-com-hjson-hjson-go
+ (package
+ (name "go-github-com-hjson-hjson-go")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hjson/hjson-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dfdiahimg6z9idg8jiqxwnlwjnmasbjccx8gnag49cz4yfqskaz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hjson/hjson-go"))
+ (home-page "https://hjson.org/")
+ (synopsis "Human JSON implementation for Go")
+ (description "Hjson is a syntax extension to JSON. It is intended to be
+used like a user interface for humans, to read and edit before passing the
+JSON data to the machine.")
+ (license license:expat)))
+
(define-public go-github-com-jcmturner-dnsutils-v2
(package
(name "go-github-com-jcmturner-dnsutils-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9fbe2d5b97..5505a6c071 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10228,30 +10228,6 @@ additions.")
(description "This package is a very simple wrapper around log/syslog")
(license license:expat)))
-(define-public go-github-com-hjson-hjson-go
- (package
- (name "go-github-com-hjson-hjson-go")
- (version "4.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hjson/hjson-go")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "138vmbnrwzxf64cia27k407clrydvs2jx927dlv6ziydiqyvy7m3"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/hjson/hjson-go"))
- (home-page "https://hjson.org/")
- (synopsis "Human JSON implementation for Go")
- (description "Hjson is a syntax extension to JSON. It is intended to be
-used like a user interface for humans, to read and edit before passing the
-JSON data to the machine.")
- (license license:expat)))
-
(define-public go-golang-zx2c4-com-wireguard
(package
(name "go-golang-zx2c4-com-wireguard")
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index dad217beb0..c3796f7328 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -123,6 +123,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-web)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index e10de59aa2..1626c90c36 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages uucp)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-web)
#:use-module (gnu packages texinfo)
#:use-module (guix licenses)
#:use-module (guix packages)