summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:48:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:52:03 +0000
commitad871fd17ff4223d1137239d06fad63244e1847a (patch)
treec93a8095045fdbb1c09d0952cee772adcc712f13
parent834c63905322ac0f8f48168cc63d3d360f499e58 (diff)
gnu: go-structlayout-pretty: Fix build.
* gnu/packages/golang-check.scm (go-structlayout-pretty) [arguments] <#:go>: Swap to go-1.20. Change-Id: I3afe393468d69e8ec78c6bb62d8ac6714b15a611
-rw-r--r--gnu/packages/golang-check.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 64e455d98f..324bf47aa7 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -718,7 +718,8 @@ into @code{go-structlayout-pretty}.")))
(inherit go-honnef-co-go-tools)
(name "go-structlayout-pretty")
(arguments
- `(#:import-path "honnef.co/go/tools/cmd/structlayout-pretty"
+ `(#:go ,go-1.20
+ #:import-path "honnef.co/go/tools/cmd/structlayout-pretty"
#:unpack-path "honnef.co/go/tools"
#:install-source? #f))
(synopsis "Format the output of go-structlayout with ASCII art in Go")