summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:04 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-20 08:31:05 -0500
commitae90aaa60cbfd9a05b0d9f9c4d6963187e0fa6e1 (patch)
tree4696f13d55417dd8e0bc315da0bc5cd5698e6fcf
parent35cbf0c04a223a08dd460e0688d34547d7f4f91f (diff)
gnu: Rename go-golang-org-colorful to go-github-com-lucasb-eyer-go-colorful.
* gnu/packages/golang.scm (go-golang-org-colorful): Deprecate and rename to... (go-github-com-lucasb-eyer-go-colorful): ...this. (go-github-com-gdamore-tcell)[inputs]: Rename go-golang-org-colorful to go-github-com-lucasb-eyer-go-colorful. (go-github-com-muesli-termenv)[inputs]: Likewise. (go-github-com-charmbracelet-glamour)[inputs]: Likewise. (go-github-com-charmbracelet-bubbletea)[inputs]: Likewise. * gnu/packages/configuration-management.scm (chezmoi)[native-inputs]: Rename go-golang-org-colorful to go-github-com-lucasb-eyer-go-colorful. * gnu/packages/image-viewers.scm (pixterm)[inputs]: Likewise. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/configuration-management.scm2
-rw-r--r--gnu/packages/golang.scm37
-rw-r--r--gnu/packages/image-viewers.scm2
3 files changed, 24 insertions, 17 deletions
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index c64b937fe5..3ebb6957c8 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -76,7 +76,7 @@
go-github-com-muesli-reflow-padding
go-github-com-muesli-termenv
go-github-com-google-goterm
- go-golang-org-colorful
+ go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
go-github.com-mattn-go-runewidth
go-github-com-olekukonko-tablewriter
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b862e5249..33ea1f40a8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5894,9 +5894,9 @@ without requiring a real database connection.")
golang's database/sql package.")
(license license:mpl2.0)))
-(define-public go-golang-org-colorful
+(define-public go-github-com-lucasb-eyer-go-colorful
(package
- (name "go-golang-org-colorful")
+ (name "go-github-com-lucasb-eyer-go-colorful")
(version "1.2.0")
(source (origin
(method git-fetch)
@@ -5908,17 +5908,20 @@ golang's database/sql package.")
(base32
"08c3fkf27r16izjjd4w94xd1z7w1r4mdalbl53ms2ka2j465s3qs"))))
(build-system go-build-system)
+ (propagated-inputs (list go-golang-org-x-image))
(arguments
- '(#:import-path "github.com/lucasb-eyer/go-colorful"))
- (native-inputs
- (list go-golang-org-sql-mock))
- (synopsis "Convert between colorspaces and generate colors")
- (description "This package implements Go's @code{color.Color} interface
-and provides a means of converting colors stored as RGB to various
-colorspaces.")
+ (list #:import-path "github.com/lucasb-eyer/go-colorful"))
(home-page "https://github.com/lucasb-eyer/go-colorful")
+ (synopsis "Library for playing with colors in Go")
+ (description
+ "The colorful package provides a library for using colors in Go.
+It stores colors in RGB and provides methods for converting these to
+various color spaces.")
(license license:expat)))
+(define-public go-golang-org-colorful
+ (deprecated-package "go-golang-org-colorful" go-github-com-lucasb-eyer-go-colorful))
+
(define-public go-github-com-gdamore-encoding
(package
(name "go-github-com-gdamore-encoding")
@@ -5966,8 +5969,10 @@ non-UTF-friendly sources.")
(arguments
`(#:import-path "github.com/gdamore/tcell"))
(inputs
- (list go-github.com-mattn-go-runewidth go-golang-org-colorful
- go-golang-org-x-text go-github-com-gdamore-encoding))
+ (list go-github.com-mattn-go-runewidth
+ go-github-com-lucasb-eyer-go-colorful
+ go-golang-org-x-text
+ go-github-com-gdamore-encoding))
(home-page "https://github.com/gdamore/tcell")
(synopsis "Provide a cell-based view for text terminals")
(description "This package includes a full parser and expander for
@@ -7716,8 +7721,10 @@ io.Writers helping you to transform blocks of text.")
(arguments
`(#:import-path "github.com/muesli/termenv"))
(native-inputs
- (list go-github-com-google-goterm go-golang-org-colorful
- go-github-com-mattn-go-isatty go-github.com-mattn-go-runewidth))
+ (list go-github-com-google-goterm
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-mattn-go-isatty
+ go-github.com-mattn-go-runewidth))
(home-page "https://github.com/muesli/termenv/")
(synopsis "Advanced styling options on the terminal")
(description "termenv lets you safely use advanced styling options on the
@@ -7846,7 +7853,7 @@ which produce colorized output using github.com/fatih/color.")
go-github.com-mattn-go-runewidth
go-github-com-muesli-termenv
go-github-com-google-goterm
- go-golang-org-colorful
+ go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
go-github-com-olekukonko-tablewriter
go-github-com-yuin-goldmark
@@ -9693,7 +9700,7 @@ string.")
("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
- ("go-golang-org-colorful" ,go-golang-org-colorful)
+ ("go-github-com-lucasb-eyer-go-colorful" ,go-github-com-lucasb-eyer-go-colorful)
("github.com/containerd/console" ,go-github-com-containerd-console)
("go-github-com-muesli-reflow-truncate" ,go-github-com-muesli-reflow-truncate)
("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 77979e8b8f..037c141065 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -532,7 +532,7 @@ It supports JPEG, PNG and GIF formats.")
'(#:import-path "github.com/eliukblau/pixterm/cmd/pixterm"
#:unpack-path "github.com/eliukblau/pixterm"))
(inputs (list go-github-com-disintegration-imaging
- go-golang-org-colorful
+ go-github-com-lucasb-eyer-go-colorful
go-golang-org-x-crypto
go-golang-org-x-image))
(home-page "https://github.com/eliukblau/pixterm")