summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-11 17:09:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:08:01 -0400
commitb18feb09d421457a337fd56b38c90994e9c99509 (patch)
tree6f12239c51ae99c48b6919f6dfe4021ddbc59207
parent4bd2d4d0484a5616d5b9923f140013cdf5899414 (diff)
refresh: Add --target-version option.
* guix/scripts/refresh.scm (%options): Register 'target-version' long version. (update-specification->update-spec): Add a fallback-version argument. (options->update-specs): Honor target-version option. * tests/guix-refresh.sh: Test it. * doc/guix.texi (Invoking guix refresh): Document it. Reviewed-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--doc/guix.texi20
-rw-r--r--guix/scripts/refresh.scm31
-rw-r--r--tests/guix-refresh.sh7
3 files changed, 50 insertions, 8 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 8469d09245..b50feed4c4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -14529,6 +14529,26 @@ gnu/packages/guile.scm:147:2: guile: updating from version 2.0.10 to version 2.0
@dots{}
@end example
+In some specific cases, you may have many packages specified via a
+manifest or a module selection which should all be updated together; for
+these cases, the @option{--target-version} option can be provided to have
+them all refreshed to the same version, as shown in the examples below:
+
+@example
+$ guix refresh qtbase qtdeclarative --target-version=6.5.2
+gnu/packages/qt.scm:1248:13: qtdeclarative would be upgraded from 6.3.2 to 6.5.2
+gnu/packages/qt.scm:584:2: qtbase would be upgraded from 6.3.2 to 6.5.2
+@end example
+
+@example
+$ guix refresh --manifest=qt5-manifest.scm --target-version=5.15.10
+gnu/packages/qt.scm:1173:13: qtxmlpatterns would be upgraded from 5.15.8 to 5.15.10
+gnu/packages/qt.scm:1202:13: qtdeclarative would be upgraded from 5.15.8 to 5.15.10
+gnu/packages/qt.scm:1762:13: qtserialbus would be upgraded from 5.15.8 to 5.15.10
+gnu/packages/qt.scm:2070:13: qtquickcontrols2 would be upgraded from 5.15.8 to 5.15.10
+@dots{}
+@end example
+
Sometimes the upstream name differs from the package name used in Guix,
and @command{guix refresh} needs a little help. Most updaters honor the
@code{upstream-name} property in package definitions, which can be used
diff --git a/guix/scripts/refresh.scm b/guix/scripts/refresh.scm
index a9241aa20d..f39dc743b1 100644
--- a/guix/scripts/refresh.scm
+++ b/guix/scripts/refresh.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -106,6 +107,9 @@
(option '(#\m "manifest") #t #f
(lambda (opt name arg result)
(alist-cons 'manifest arg result)))
+ (option '("target-version") #t #f
+ (lambda (opt name arg result)
+ (alist-cons 'target-version arg result)))
(option '(#\e "expression") #t #f
(lambda (opt name arg result)
(alist-cons 'expression arg result)))
@@ -165,6 +169,9 @@ specified with `--select'.\n"))
(display (G_ "
-m, --manifest=FILE select all the packages from the manifest in FILE"))
(display (G_ "
+ --target-version=VERSION
+ update the package or packages to VERSION"))
+ (display (G_ "
-t, --type=UPDATER,... restrict to updates from the specified updaters
(e.g., 'gnu')"))
(display (G_ "
@@ -213,17 +220,20 @@ specified with `--select'.\n"))
(define* (update-spec package #:optional version)
(%update-spec package version))
-(define (update-specification->update-spec spec)
+(define (update-specification->update-spec spec fallback-version)
"Given SPEC, a package name like \"guile@2.0=2.0.8\", return a <update>
-record with two fields: the package to upgrade, and the target version."
+record with two fields: the package to upgrade, and the target version. When
+SPEC lacks a version, use FALLBACK-VERSION."
(match (string-rindex spec #\=)
- (#f (update-spec (specification->package spec) #f))
+ (#f (update-spec (specification->package spec) fallback-version))
(idx (update-spec (specification->package (substring spec 0 idx))
(substring spec (1+ idx))))))
(define (options->update-specs opts)
"Return the list of <update-spec> records requested by OPTS, honoring
options like '--recursive'."
+ (define target-version (assoc-ref opts 'target-version))
+
(define core-package?
(let* ((input->package (match-lambda
((name (? package? package) _ ...) package)
@@ -263,13 +273,18 @@ update would trigger a complete rebuild."
;; Update specs explicitly passed as command-line arguments.
(match (append-map (match-lambda
(('argument . spec)
- ;; Take either the specified version or the
- ;; latest one.
- (list (update-specification->update-spec spec)))
+ ;; Take either the specified version or the latest
+ ;; one. The version specified as part of a spec
+ ;; takes precedence, with the command-line specified
+ ;; --target-version used as a fallback.
+ (list (update-specification->update-spec
+ spec target-version)))
(('expression . exp)
- (list (update-spec (read/eval-package-expression exp))))
+ (list (update-spec (read/eval-package-expression exp)
+ target-version)))
(('manifest . manifest)
- (map update-spec (packages-from-manifest manifest)))
+ (map (cut update-spec <> target-version)
+ (packages-from-manifest manifest)))
(_
'()))
opts)
diff --git a/tests/guix-refresh.sh b/tests/guix-refresh.sh
index 51d34c4b51..2ce3c592ab 100644
--- a/tests/guix-refresh.sh
+++ b/tests/guix-refresh.sh
@@ -109,6 +109,13 @@ case "$(guix refresh -t test guile=2.0.0 2>&1)" in
*"failed to find"*"2.0.0"*) true;;
*) false;;
esac
+
+guix refresh -t test guile --target-version=2.0.0 # XXX: should return non-zero?
+case "$(guix refresh -t test guile --target-version=2.0.0 2>&1)" in
+ *"failed to find"*"2.0.0"*) true;;
+ *) false;;
+esac
+
for spec in "guile=1.6.4" "guile@3=1.6.4"
do
guix refresh -t test "$spec"