summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-03-28 19:51:21 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-03-31 00:29:35 +0530
commitb19a960f5fc0e98efd64828a0818be0724e5f3a6 (patch)
treea8d627fc3dde2babf6f78534c30e14bfa9d3c7e5
parent180b6f3baaa33d922f8604559320a5a00f38f894 (diff)
gnu: python-hypothesis: Update to 3.52.0.
* gnu/packages/check.scm (python-hypothesis): Update to 3.52.0. [propagated-inputs]: Add python-attrs and python-coverage. [home-page]: Update URI. * gnu/packages/python.scm (python-attrs-bootstrap, python2-attrs-bootstrap): New variables.
-rw-r--r--gnu/packages/check.scm11
-rw-r--r--gnu/packages/python.scm10
2 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 9d3d036725..e99d44a56a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
@@ -1358,23 +1358,26 @@ normally the case.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "3.1.0")
+ (version "3.52.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0qyqq9akm4vshhn8cngjc1qykcvsn7cz6dlm6njfsgpbraqrmbbw"))))
+ "0g54cypfi5qj6cgxfr7l1nb41r1cqhhngx4qxn4ga9h720rcsbr8"))))
(build-system python-build-system)
(native-inputs
`(("python-flake8" ,python-flake8)
("python-pytest" ,python-pytest-bootstrap)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs-bootstrap)
+ ("python-coverage" ,python-coverage)))
(synopsis "Library for property based testing")
(description "Hypothesis is a library for testing your Python code against a
much larger range of examples than you would ever want to write by hand. It’s
based on the Haskell library, Quickcheck, and is designed to integrate
seamlessly into your existing Python unit testing work flow.")
- (home-page "https://github.com/DRMacIver/hypothesis")
+ (home-page "https://github.com/HypothesisWorks/hypothesis-python")
(license license:mpl2.0)
(properties `((python2-variant . ,(delay python2-hypothesis))))))
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dc082f61a2..f5de8cedc0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10778,6 +10778,16 @@ protocols.")
(define-public python2-attrs
(package-with-python2 python-attrs))
+(define-public python-attrs-bootstrap
+ (package
+ (inherit python-attrs)
+ (name "python-attrs-bootstrap")
+ (native-inputs `())
+ (arguments `(#:tests? #f))))
+
+(define-public python2-attrs-bootstrap
+ (package-with-python2 python-attrs-bootstrap))
+
(define-public python2-cliapp
(package
(name "python2-cliapp")