summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-04-20 18:15:03 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-05-10 09:32:49 +0200
commitb5b20bda17acfce8802e067f1ca015c65f4d3cf8 (patch)
tree36a9f201e479cfa77215df60ca8675f75c62d742
parentce426deb8a4b6132919200ea956f10c4269c9550 (diff)
gnu: Add dvdauthor.
* gnu/packages/video.scm (dvdauthor): New variable.
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e7af81e728..dde4041449 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
@@ -1193,6 +1195,33 @@ authentication and descrambling (if an external libdvdcss library is
installed).")
(license license:gpl2+)))
+(define-public dvdauthor
+ (package
+ (name "dvdauthor")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/dvdauthor/dvdauthor-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1drfc47hikfzc9d7hjk34rw10iqw01d2vwmn91pv73ppx4nsj81h"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libdvdread" ,libdvdread)
+ ("libpng" ,libpng)
+ ("imagemagick" ,imagemagick)
+ ("libxml2" ,libxml2)
+ ("freetype" ,freetype)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Generates a DVD-Video movie from a MPEG-2 stream")
+ (description "@command{dvdauthor} will generate a DVD-Video movie from a
+MPEG-2 stream containing VOB packets.")
+ (home-page "http://dvdauthor.sourceforge.net")
+ (license license:gpl3+)))
+
(define-public libdvdnav
(package
(name "libdvdnav")