summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2024-01-08 10:54:27 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-02-10 21:00:03 +0100
commitb64862e5cb8209c92aa2eff4cec0be328e38c45d (patch)
tree0f06a271febe09c835354b98fd4ab94f32e26822
parente94e8eaeddafad9cc0fb54d0e14e7aa913b3eb20 (diff)
gnu: gnupg: Fix cross-compilation.
* gnu/packages/gnupg.scm (gnupg)[arguments]: Pass libraries prefixes when cross-crompiling. Change-Id: I461ba02ddf5bb23277bd6685c2106e4ad37e2184 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/gnupg.scm32
1 files changed, 27 insertions, 5 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 171eea6600..9a02635ec1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -346,11 +346,33 @@ compatible to GNU Pth.")
zlib))
(arguments
(list
- #:configure-flags #~'(;; Otherwise, the test suite looks for the `gpg`
- ;; executable in its installation directory in
- ;; /gnu/store before it has been installed.
- "--enable-gnupg-builddir-envvar"
- "--enable-all-tests")
+ #:configure-flags
+ ;; Always use quasiquote on the next core-updates cycle.
+ #~(#$(if (%current-target-system)
+ #~quasiquote
+ #~quote)
+ (#$@(if (%current-target-system)
+ #~(,(string-append
+ "--with-libgpg-error-prefix="
+ #$(this-package-input "libgpg-error"))
+ ,(string-append
+ "--with-libgcrypt-prefix="
+ #$(this-package-input "libgcrypt"))
+ ,(string-append
+ "--with-libassuan-prefix="
+ #$(this-package-input "libassuan"))
+ ,(string-append
+ "--with-ksba-prefix="
+ #$(this-package-input "libksba"))
+ ,(string-append
+ "--with-npth-prefix="
+ #$(this-package-input "npth")))
+ #~())
+ ;; Otherwise, the test suite looks for the `gpg`
+ ;; executable in its installation directory in
+ ;; /gnu/store before it has been installed.
+ "--enable-gnupg-builddir-envvar"
+ "--enable-all-tests"))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'patch-paths