summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:19:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:51 +0200
commitbd12824e56cfcbf13fa9564c0efa42c3a9430d8b (patch)
tree54e784e79d125a636afd6cf268d9e8c9a6cf2ebb
parent30302ded0df49984b6c532af071633b968a0f48b (diff)
gnu: texlive-latex-float -> texlive-float.
* gnu/packages/tex.scm (texlive-float): New variable. (texlive-latex-float): Deprecate variable. (texlive-showexpl): (texlive-minted): (texlive-apa6): * gnu/packages/docbook.scm (dblatex): * gnu/packages/maths.scm (hypre): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): Use new name.
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/tex.scm41
5 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 709f45eda7..7ff920409e 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -543,7 +543,7 @@ the in DocBook SGML DTDs.")
texlive-fancybox
texlive-fancyhdr
texlive-fancyvrb
- texlive-latex-float
+ texlive-float
texlive-footmisc
texlive-hyperref
texlive-latex-jknapltx
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c859b1d97a..af8efd3ca3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5800,7 +5800,7 @@ set.")
texlive-listofitems
texlive-cmap
texlive-colortbl
- texlive-latex-float
+ texlive-float
texlive-fncychap
texlive-framed
texlive-geometry
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7edaf1dbc8..ceee6ba98a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15186,7 +15186,7 @@ time.")
texlive-grffile
texlive-hyperref
texlive-fancyvrb
- texlive-latex-float
+ texlive-float
texlive-geometry
texlive-latex-jknapltx
texlive-ms
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 906b05e979..a69a8b44ed 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -116,7 +116,7 @@
texlive-cmap
texlive-fancyhdr
texlive-fancyvrb
- texlive-latex-float
+ texlive-float
texlive-fncychap
texlive-framed
texlive-geometry
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e2fe4c11a1..16f6b71da9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5632,7 +5632,7 @@ user may consider the @code{dnaseq} as a rather more powerful alternative.")
(build-system texlive-build-system)
(propagated-inputs
(list texlive-attachfile
- texlive-latex-float
+ texlive-float
texlive-graphics
texlive-listings
texlive-refcount
@@ -6665,30 +6665,31 @@ LaTeX would automatically change the heading style in use).")
(define-deprecated-package texlive-latex-fancyhdr texlive-fancyhdr)
-(define-public texlive-latex-float
+(define-public texlive-float
(package
- (name "texlive-latex-float")
+ (name "texlive-float")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "float"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0nbl7wylkv22fcdv4p8byhhj575fli6jnqjpkhrkbv8dzwah84nq"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/float/"
+ "source/latex/float/"
+ "tex/latex/float/")
+ (base32
+ "1rfyvk1n83zsmrrp0x643052nrjb00cj935d2cpm37x4pz649f5d")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/float"))
- (home-page "https://www.ctan.org/pkg/float")
+ (home-page "https://ctan.org/pkg/float")
(synopsis "Improved interface for floating objects")
(description
- "This package improves the interface for defining floating objects such
-as figures and tables. It introduces the boxed float, the ruled float and the
-plaintop float. You can define your own floats and improve the behaviour of
-the old ones. The package also provides the @code{H} float modifier option of
-the obsolete @code{here} package. You can select this as automatic default
-with @code{\\floatplacement{figure}{H}}.")
+ "The @code{float} package improves the interface for defining floating
+objects such as figures and tables. It introduces the boxed float, the ruled
+float and the plaintop float. You can define your own floats and improve the
+behaviour of the old ones. The package also provides the @samp{H} float
+modifier option of the obsolete @code{here} package.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-float texlive-float)
+
(define-public texlive-footmisc
(package
(name "texlive-footmisc")
@@ -10657,7 +10658,7 @@ configuration of its own fixed names, using @file{.mld} files.")
(propagated-inputs (list python-pygments
texlive-etoolbox
texlive-fancyvrb
- texlive-latex-float
+ texlive-float
texlive-framed
texlive-fvextra
texlive-ifplatform
@@ -11878,7 +11879,7 @@ and selecting references used in a publication.")
texlive-fancyhdr
texlive-xstring
texlive-graphics
- texlive-latex-float
+ texlive-float
texlive-lm
texlive-substr
texlive-times