summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 18:28:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:29 +0000
commitc21f468cf16758b99de950a2d64afb83aa275349 (patch)
tree6a181aaeda30c7239decbe623d69f24e03099898
parent532914a389ca0b8462db1b91e92d226559a599e0 (diff)
gnu: go-github-com-cheggaaa-pb-v3: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-cheggaaa-pb-v3): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/golang.scm (go-github-com-cheggaaa-pb): Remove variable. Change-Id: Ieddfddfec841e5b35c14002dbfe8655a7b5dec0f
-rw-r--r--gnu/packages/golang-xyz.scm30
-rw-r--r--gnu/packages/golang.scm32
2 files changed, 30 insertions, 32 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 28bd13018f..645b979e11 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
@@ -351,6 +352,35 @@ quantiles over an unbounded data stream within low memory and CPU bounds.")
similar to Go's standard library @code{json} and @code{xml} package.")
(license license:expat)))
+(define-public go-github-com-cheggaaa-pb-v3
+ (package
+ (name "go-github-com-cheggaaa-pb-v3")
+ (version "3.0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cheggaaa/pb/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0d701s2niy39r650d1phjw19h4l27b1yfc2ih6s31f56b3zzqspx"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/cheggaaa/pb/v3"
+ #:unpack-path "github.com/cheggaaa/pb"))
+ (propagated-inputs
+ (list go-github-com-fatih-color
+ go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-github-com-vividcortex-ewma))
+ (home-page "https://github.com/cheggaaa/pb/")
+ (synopsis "Console progress bar for Go")
+ (description
+ "This package is a Go library that draws progress bars on the terminal.")
+ (license license:bsd-3)))
+
(define-public go-github-com-coocood-freecache
(package
(name "go-github-com-coocood-freecache")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 59107ec762..ac4c24e487 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8754,38 +8754,6 @@ error messages.")
inspired by the causal messaging system in the Pony programming language.")
(license license:expat))))
-(define-public go-github-com-cheggaaa-pb-v3
- (package
- (name "go-github-com-cheggaaa-pb-v3")
- (version "3.0.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cheggaaa/pb/")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0d701s2niy39r650d1phjw19h4l27b1yfc2ih6s31f56b3zzqspx"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/cheggaaa/pb/v3"
- #:unpack-path "github.com/cheggaaa/pb"))
- (propagated-inputs
- (list go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-colorable
- go-github-com-fatih-color
- go-github-com-vividcortex-ewma))
- (home-page "https://github.com/cheggaaa/pb/")
- (synopsis "Console progress bar for Go")
- (description "This package is a Go library that draws progress bars on
-the terminal.")
- (license license:bsd-3)))
-
-(define-public go-github-com-cheggaaa-pb
- (deprecated-package "go-github-com-cheggaaa-pb" go-github-com-cheggaaa-pb-v3))
-
(define-public go-github-com-gologme-log
;; this is the same as v1.2.0, only the LICENSE file changed
(let ((commit "720ba0b3ccf0a91bc6018c9967a2479f93f56a55"))