summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:37 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 15:14:13 -0400
commitc7e222298ef2e3d45cae72f3e1f95a1d96771d31 (patch)
treef0ceea07e6b2cae7e34da14d1dca15471d0399b6
parent7bc1d1239d91383d7ed444b22387b49495acc003 (diff)
gnu: lightdm: Explicitely use a native 'bash' for 'wrap-program'.
Having to use a native bash for 'wrap-program' is fairly unusual, but here it is the right thing, as it is for the test suite only. Placate the 'wrapper-inputs' linter. Also, eventually we might consider letting 'wrap-program' bail out if no bash for the host is found, even when compiling natively. But that's for later. * gnu/packages/display-managers.scm (lightdm)[arguments]<#:phases>{pre-check}: Set #:sh argument of 'pre-check' Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/display-managers.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 327a29aa9e..d3711ee6eb 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -309,6 +309,7 @@ experience for your users, your family and yourself")
(add-before 'check 'pre-check
(lambda _
(wrap-program "tests/src/test-python-greeter"
+ #:sh (which "bash")
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
;; Avoid printing locale warnings, which trip up the text