summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-03 15:41:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-03 15:43:25 +0100
commitcad1789b3ea7317fd41a6a26c633a0ee88fe7a81 (patch)
tree63d8006052ef9295e323542e10b9470adb24b7e8
parent71ee1fbbed8ea9788dd48a634653d66606d372ce (diff)
gnu: Add python-bcbio-gff.
* gnu/packages/bioinformatics.scm (python-bcbio-gff): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 46febf579a..a92589eef7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -907,6 +907,26 @@ input/output delimiter. When the new functionality is not used, bioawk is
intended to behave exactly the same as the original BWK awk.")
(license license:x11)))
+(define-public python-bcbio-gff
+ (package
+ (name "python-bcbio-gff")
+ (version "0.6.9")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "bcbio-gff" version))
+ (sha256
+ (base32
+ "1pm1szyxabhn8jismrj9cjhf88ajgcmm39f0cgf36iagw5qakprl"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-biopython python-six))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/chapmanb/bcbb/tree/master/gff")
+ (synopsis "Read and write GFF files with Biopython integration")
+ (description
+ "This package lets you read and write files in Generic Feature
+Format (GFF) with Biopython integration.")
+ (license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))))
+
(define-public python-cellbender
(package
(name "python-cellbender")