summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:02:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:49 +0200
commitcd56be10c1dfad55dbc821eaeab1293039926329 (patch)
tree748cf6d9d152072796b3f60a61a94916bd35e9e4
parent2b0bfc23c6af9df9ede8da7f9aaf25c83fb0a053 (diff)
gnu: Add texlive-theanomodern.
* gnu/packages/tex.scm (texlive-theanomodern): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fac71b9980..f2961c5d3a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24857,6 +24857,33 @@ modern LaTeX processors. An artificially-emboldened variant has been provided
but there are no italic variants.")
(license (list license:lppl license:silofl1.1))))
+(define-public texlive-theanomodern
+ (package
+ (name "texlive-theanomodern")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/theanomodern/"
+ "fonts/enc/dvips/theanomodern/"
+ "fonts/map/dvips/theanomodern/"
+ "fonts/tfm/public/theanomodern/"
+ "fonts/truetype/public/theanomodern/"
+ "fonts/type1/public/theanomodern/"
+ "fonts/vf/public/theanomodern/"
+ "tex/latex/theanomodern/")
+ (base32
+ "17s04wcliqn5sgg5d6axc5ky3wg7xzh62c83hgrf3fq3pbykwm77")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/theanomodern")
+ (synopsis "Theano Modern fonts with LaTeX support")
+ (description
+ "This package provides the TheanoModern font designed by Alexey Kryukov,
+in both TrueType and Type1 formats, with support for both traditional and
+modern LaTeX processors. An artificially-emboldened variant has been provided
+but there are no italic variants.")
+ (license (list license:silofl1.1 license:lppl))))
+
(define-public texlive-theatre
(package
(name "texlive-theatre")