summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-04-25 18:01:40 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-05-10 09:32:48 +0200
commitce426deb8a4b6132919200ea956f10c4269c9550 (patch)
tree5d5b3673fe7a50bfc4e67c9f012dbaed932b0736
parent76e98457347207459417f46c2f542b6a9f03fb7f (diff)
gnu: brasero: Embed growisofs store item.
* gnu/packages/gnome.scm (brasero)[arguments]: Add phase 'embed-growisofs. [inputs]: Add dvd+rw-tools.
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ef67961ab8..cec8baebfe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -150,7 +150,14 @@
"/share/gir-1.0")
(string-append "--with-typelibdir="
(assoc-ref %outputs "out")
- "/lib/girepository-1.0"))))
+ "/lib/girepository-1.0"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'embed-growisofs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "plugins/growisofs/burn-growisofs.c"
+ (("\"growisofs") (string-append "\"" (which "growisofs"))))
+ #t )))))
(propagated-inputs
`(("hicolor-icon-theme" ,hicolor-icon-theme)))
(native-inputs
@@ -159,7 +166,8 @@
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)))
(inputs
- `(("glib" ,glib)
+ `(("dvd+rw-tools" ,dvd+rw-tools)
+ ("glib" ,glib)
("gnome-doc-utils" ,gnome-doc-utils)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)